2
Vote

Driver Error

description

When I install the driver and try to connect to Sharepoint http://myservername I get the error (Error: Value cannnot be null. Parameter name: Path1)
 
Can you help?

file attachments

comments

theiwaz wrote Feb 7, 2012 at 10:49 AM

To help you out I need some more information:
  • are you running SharePoint locally on the same machine where LinqPad is installed?
  • which Version of linqpad and windows you are running?
  • could you please provide me the steps to reproduce the error?
  • are you running the static or the dynamic driver?
  • can you provide the linqpad log file? This file is usually found at %userprofile%\AppData\Local\LINQPad\Logs

theiwaz wrote Feb 7, 2012 at 10:50 AM

Sorry I forgot to ask which release of the Context Driver you are running?

wrote Feb 7, 2012 at 10:51 AM

wrote Feb 8, 2012 at 10:39 AM

ckotsis wrote Feb 8, 2012 at 10:40 AM

hi,

1) Locally where LiqPad is installed and I've also tried a distant server
2) LinqPad4
3) I just install the driver and use the dynamic version. When I enter the http://<servername>/ and try to populate I get the error
4) file attached

ckotsis wrote Feb 8, 2012 at 10:40 AM

The driver is the last one that is now online

theiwaz wrote Feb 10, 2012 at 10:02 AM

hi,

you are running LinqPad4 which is running in a .NET 4 process. SharePoint does allow access to the object model only via .NET 3.5. I always wanted to add code to check this but I missed it till now ;-)
Could you please give it as try with LinqPad v2.3.1 for .NET 3.5?

ckotsis wrote Feb 13, 2012 at 7:47 AM

It seems to be working now, but still got issues when trying to run queries. I will test further!

wrote Jun 6, 2012 at 12:23 AM

umaxfun wrote Jun 6, 2012 at 12:25 AM

+1 to the topic. It never worked for me =(

theiwaz wrote Jun 26, 2012 at 7:25 AM

@umaxfun: does this issue still exists? If so which version of linqpad do you use? can you provide the log file?

wrote Feb 14, 2013 at 12:01 AM